Go to All Forums

Ending .NET 2.0 monitoring support

As announced in an earlier post, Site24x7—and by extension, APM Insight—is ending support at the end of July 2018 for TLS 1.0 and 1.1 protocols in our agents, clients, and servers. 

Implications for monitoring .NET applications 

Please note that .NET supports TLS 1.2 protocol only beginning with version 4.5, and Microsoft has stopped supporting all prior versions of .NET. That means applications compiled in .NET 2.0, 3.0, 3.5, and 4.0 will no longer be able to communicate with Site24x7 services after July 2018. 

Changes in the .NET agent 

To support TLS 1.2, we have recompiled our agents in .NET 4.5; because of this, we are ending monitoring support for .NET applications built on .NET 2.0, 3.0, and 3.5. You can still monitor applications compiled on .NET 4.0, provided .NET 4.5 is installed on your system. 

Here are the minimum requirements for the new .NET agent:

  • Operating system: Windows Server 2008 R2 and above

  • Installation: .NET framework version 4.5 and above

  • Monitoring: CLR version 4.0.30319 and above

If you're monitoring applications compiled on .NET 4.0 and above, please upgrade your agents to APM Insight .NET agent v4.0 before July 2018 to avoid any disruption in monitoring. Keep in mind that you can schedule an automatic update of .NET from Site24x7

Reply 0
Replies (0)