Go to All Forums

Unable to succesfully add GCP monitor. No discovery happens (or hardly any)

I'm trying to add a GCP monitor, but it is 'discovering' for hours. ("Your GCP resources are being discovered, this may take a while."  keeps being displayed).  In 2nd browser window I can see that it has disovered a Kubernetes cluster, but that's all. No VM Instances/disks/storage/etc.  And the only information it gathered from the GKE cluster is the configuration details.  All other information (CPU usage/disk etc is empty). Also no information on what is running within the cluster.

I've also tried to install the metrics agent (not sure if this is needed for getting even basic information on the cluster), and although the metrics pod is running, it is flooding the logs with :

Failed to list *v1beta1.ReplicaSet: the server could not find the requested resource

(we're running 1.19.9-gke.100)

The service account I've setup does have the required Viewer role, so not sure what else to do to get this discovery (of i.e. VMs and storage etc outside of the K8S cluster) working. 

 

 

Like (2) Reply
Replies (2)

Re: Unable to succesfully add GCP monitor. No discovery happens (or hardly any)

Hi,

Please refer to this article and check for possible reasons as to why the GCP resources have not been added for monitoring.

If the issue still persists, please comment in the below thread. If sharing any sensitive content, send as email to support@site24x7.com 

 

Regards,

Perumal

Like (0) Reply

Re: Re: Unable to succesfully add GCP monitor. No discovery happens (or hardly any)

Thanks.  It turned out we had to few monitor licenses left. The discovery added 40+ monitors in our case.

Like (1) Reply

Was this post helpful?