Participate in exciting contests this SysAdmin Day for a chance to win a $50 gift card. Join the fun!
Go to All Forums

Can APM php agent support Centos 6 (6.9)?

Hi, all our production servers are running Centos 6.9. When I follow the APM php agent installation guide here ( It always fails due to 

GLIBC version too low.


[root@server6 bin]# sudo sh us_f4e336487890xxxxxxxxxxxxxxxxxxx

./installer: /lib64/ version `GLIBC_2.14' not found (required by ./installer)

Error while installing phpagent


I believe all Centos 6 OS only comes with GLIBC 2.12. Is there any way I can install the php agent in Centos 6 system? Some suggest we can force GLIBC 1.4 to be installed in the Centos 6.x, but more others against the idea, as it may introduce long term instability issue to the production system. Please advice.




Like (1) Reply
Replies (3)

Re: Can APM php agent support Centos 6 (6.9)?


Please be informed that PHP Agent is built to be compatible with CentOS and almost any flavor of Linux (except Alpine). You are seeing this error because the installer was built with GLIBC 2.14 version. You can find an older version of the PHP agent compatible with your GLIBC version in the following kbase article.

Hope that helps, 

Thanks & Regards,

Shrinivasan S S

Developer, APM Insight 

Like (0) Reply

Re: Re: Can APM php agent support Centos 6 (6.9)?


I'm having the same issue (GLIBC 2.14 not found), tried to install agent_php_2_4 and I'm receiving a different error (php version not supported):

Error in installation :: PHP version not supported
Please contact technical support
Error while installing phpagent
[/opt/zpa/bin]# php -v
PHP 5.5.38 (cli) (built: Apr 23 2019 17:54:29)

Based on your documentation, the PHP version should be supported.
Could you please let me know if there is an issue with PHP agent 2.4?



Like (0) Edit Delete Reply

Re: Re: Re: Can APM php agent support Centos 6 (6.9)?

Dear Guest, 

Kindly note that PHP 2.4 agent attached in the kbase, supports NTS versions of PHP from 5.3 through 7.2. It is only the installer and not the extension modules, which is compiled in the previous versions of GLIBC. 

To verify if the agent is compatible manually, you can do the following, 

1. Run command "php -i| grep API". This should print something like 

Server API => Command Line Interface
PHP API => 20090626
Zend Extension Build => API220090626,NTS
PHP Extension Build => API20090626,NTS

2. Check the /opt/zpa/lib folder. You should see a library of the format where XXXX is the PHP API version. Currently (in our live agent) we support the following API versions

  • 20090626(v5.3),
  • 20100525(v5.4),
  • 20121212(v5.5),
  • 20131226(v5.6),
  • 20151012(v7.0),
  • 201160303(v7.1), 
  • 20170718(v7.2),
  • 20180731(v7.3) 

3. If the library version is not matched, kindly let us know which version of library you're using so that we can verify and compile our agent for the specific version.

4. If your PHP runs on TS (thread safe) instead of NTS (non thread safe), we don't have support for it as of now. We regret the inconvenience and will add support in the future versions of the agent. 


Shrinivasan S S

Developer, APM Insight 

Like (0) Reply

Was this post helpful?